The bioBakery help forum

Unrecognized inputs

Hi,

I’m running kneaddata as follows but it isn’t recognising the inputs and I’m unsure what the problem is.

(biobakery3) scmb-0aegg7d:merged_L1_L2 s4$ kneaddata -i /Volumes/SCI/SCMB/Research/D/RHDStudents/S/Kneaddata_quality_control/merged_L1_L2/BBC2144_R1.fastq.gz —i /Volumes/SCI/SCMB/Research/D/RHDStudents/S/Kneaddata_quality_control/merged_L1_L2/BBC2144_R2.fastq.gz —db /Volumes/SCI/SCMB/Research/D/RHDStudents/S/Kneaddata_quality_control/human_genome/Homo_sapiens_hg37_and_human_contamination_Bowtie2_v0.1.tar.gz -o /Volumes/SCI/SCMB/Research/D/RHDStudents/S/Kneaddata_quality_control/output

usage: kneaddata [-h] [–version] [-v] -i INPUT -o OUTPUT_DIR

             [-db REFERENCE_DB] [--bypass-trim]

             [--output-prefix OUTPUT_PREFIX] [-t <1>] [-p <1>]

             [-q {phred33,phred64}] [--run-bmtagger] [--run-trf]

             [--run-fastqc-start] [--run-fastqc-end] [--store-temp-output]

             [--remove-intermediate-output] [--cat-final-output]

             [--log-level {DEBUG,INFO,WARNING,ERROR,CRITICAL}] [--log LOG]

             [--trimmomatic TRIMMOMATIC_PATH] [--max-memory MAX_MEMORY]

             [--trimmomatic-options TRIMMOMATIC_OPTIONS]

             [--bowtie2 BOWTIE2_PATH] [--bowtie2-options BOWTIE2_OPTIONS]

             [--no-discordant] [--reorder] [--serial]

             [--bmtagger BMTAGGER_PATH] [--trf TRF_PATH] [--match MATCH]

             [--mismatch MISMATCH] [--delta DELTA] [--pm PM] [--pi PI]

             [--minscore MINSCORE] [--maxperiod MAXPERIOD]

             [--fastqc FASTQC_PATH]

kneaddata: error: unrecognized arguments: —i /Volumes/SCI/SCMB/Research/D/RHDStudents/S/Kneaddata_quality_control/merged_L1_L2/BBC2144_R2.fastq.gz —db /Volumes/SCI/SCMB/Research/D/RHDStudents/S/Kneaddata_quality_control/human_genome/Homo_sapiens_hg37_and_human_contamination_Bowtie2_v0.1.tar.gz

Appreciate any help

Hi @sophieleech ,

Thank you for reaching out to bioBakery lab.

There is a little typo in your input command. Instead of --i, you are using —i. Same case for the --db as well. It is recommended to not use any auto-format editors while copy and pasting commands to avoid these errors in the future.

Thanks,
Sagun