Unable to run PhyloPhlan without trimming the msa

I’m unable to run PhyloPhlan without it trimming the msas.
Things tried:

  • Specifying --trim None while running PhyloPhlan. This gives the error: phylophlan: error: argument --trim: invalid choice: 'None' (choose from 'gap_trim', 'gap_perc', 'not_variant', 'greedy')
  • Not specifying trimal while generating the config file. This for some reason still results in trimming.

I understand that trimming is happening depending on the type of diversity specified. Is there a way to run without specifying diversity so the user can customize based on their preference? This will perhaps also require not setting --accurate as default, as that also controls several parameters.
On a similar note how do I turn OFF other parameters included with the specified diversity, eg --remove_fragmentary_entries

I’m using PhyloPhlAn version 3.0.67 (24 August 2022)