The bioBakery help forum

Problem installing humann2

Hi,

I tried a few times to install humann2 on Mac OSX.

I followed the tutorial that is on Github page.

Here are the steps that I followed and the error that ensued:

  1. I downloaded humann2 from pip as follow: pip install humann2 --no-binary :all:

  2. I tried to run a demo using the following command: humann2 --input examples/demo.fastq --output $OUTPUT_DIR

Even when doing this I am still getting the following error: “CRITICAL ERROR: The bowtie2 executable can not be found. Please check the install.”

It looks like even when downloading from the source it still did not find the essential software.

  1. I installed bowtie2 manually following the steps in their website:

_ Download the source code (by paying attention that the version is compatible with humann2)

_ brew install tbb

=> The previous error got resolved but instead this time it was: ”CRITICAL ERROR: The diamond executable can not be found.”

  1. Installing diamond have been fruitless as well with the same critical error but I was able to resolve that error by downloading an old version of diamond (v0.8.22)

  2. But now I have a critical error saying: “CRITICAL ERROR: metaphlan2 executable can not be found”

However when doing the following command: metaphlan2.py —version it looks it is defined and accessible within the path.

Trying to get older versions of metaphlan2 or Humann2 did not solve the issue.

Could you provide some support? What was the version of the different dependencies at the time of the tutorial?

1 Like

I also tried running: $ metaphlan2.py --version as you suggested in another thread but there is no error.

I would add that I am also working in a virtual env. Could it be the cause of these errors ?

Hello, Sorry to hear you are having issues installing the software. It sounds like you might be using a couple different environments at once (ie brew, virtualenv) and I believe that might be the cause of the errors. I think the dependencies are likely being installed but they might not be found in your current $PATH. If you would possibly try installing humann with just pip (adding “–user” if you want to install in your userspace), I think this should resolve the errors.

Thank you,
Lauren

Hi! I had the same issue (tried to install through pip install using the --no-binary :all: option unsuccessfully, since no dependency was installed). So I tried to install from source and there is something not working with the diamond (v0.8.22.tar.gz) installation (WARNING: Unable to install diamond. Please install diamond). I tried to install it from source and once more, didn’t work. Is there any suggestion?

Hi Sofia, If you are installing on linux humann will download the binary tar archive from diamond. However, if you are installing on MacOS humann will try to install diamond from source which will require the dependencies of gcc, make, and cmake. If you are on MacOS would you double check you have these dependencies installed and if not install them and then try installing humann with diamond again? I think this should resolve the error you are seeing.

Thank you,
Lauren

1 Like