The bioBakery help forum

PhyloPhlAn database

I tried to run phylophlan, but I couldn’t understand the error it is giving me.

I noticed that phylophlan.dmnd seems to be a very small file (104 byte). I tried to run diamond using the phylophlan.dmnd, but it wouldn’t work. I am wondering if there is a link that I can download this file from?

Thank you

Hi,

the phylophlan.dmnd should be 178M, so I guess something went wrong with diamond during the database creation.
PhyloPhlAn automatically downloads the database file and the build the index at runtime. So, you can check that the in database folder you should have a folder named phylophlan that contains: phylophlan.faa (175M) and phylophlan.faa.bz2 (65M). If this is the case, please remove the phylophlan.dmnd and re-run PhyloPhlAn. If the above 2 files have different dimensions it might be that they were not properly downloaded, so you can remove the whole database folder phylophlan and re-run PhyloPhlAn.

In re-runnning PhyloPhlAn please use the --verbose param and store the output to a file, so that you should have any problem you can also provide the output file that can help understand what’s not working.

Many thanks,
Francesco

Thank you. Removing the folder and re-running helped.

1 Like