The bioBakery help forum

MetaPhlAn3 UnboundLocalError

I’ve installed MetaPhlAn3 in my Ubuntu 64-bit machine through Anaconda3. I tried running it on a sample .fastq file. But I am getting the following error. But it is working with .sam file. But I want to work with .fastq files only. Please help me resolving this.

Downloading https://www.dropbox.com/sh/7qze7m7g9fe2xjg/AAA4XDP85WHon_eHvztxkamTa/file_list.txt?dl=1

Warning: Unable to download https://www.dropbox.com/sh/7qze7m7g9fe2xjg/AAA4XDP85WHon_eHvztxkamTa/file_list.txt?dl=1
Traceback (most recent call last):
File “/home/priya/anaconda3/bin/metaphlan”, line 10, in
sys.exit(main())
File “/home/priya/anaconda3/lib/python3.8/site-packages/metaphlan/metaphlan.py”, line 916, in main
pars[‘index’] = check_and_install_database(pars[‘index’], pars[‘bowtie2db’], pars[‘bowtie2_build’], pars[‘nproc’], pars[‘force_download’])
File “/home/priya/anaconda3/lib/python3.8/site-packages/metaphlan/init.py”, line 271, in check_and_install_database
index = resolve_latest_database(bowtie2_db, ls_f[‘mpa_latest’], force_redownload_latest)
UnboundLocalError: local variable ‘ls_f’ referenced before assignment

Please check your MetaPhlAn version, I suspect you have installed an older version (maybe 3.0). The latest version is 3.0.7

Yes. You are correct. I am using MetaPhlAn 3.0. But when I tried installing 3.0.7, it is running to some extant and abruptly getting stopped in the middle printing some proxy error like this. Please help me know what can be the issue.

ProxyError: Conda cannot proceed due to an error in your proxy configuration.
Check for typos and other configuration errors in any ‘.netrc’ file in your home directory,
any environment variables ending in ‘_PROXY’, and any other system-wide proxy
configuration settings.

I’d suggest to check your network configuration and configure conda in order to be able to fetch the packages behind a proxy.