Metaphlan with -t marker counts, not producing counts

Metaphlan version 4.0.6
mpa_vOct22_CHOCPhlAnSGB_202212

I am trying to get counts to run on a statistical model that only takes counts using metaphlan. However, my files are not showing any counts. (everything has a count of 0).

Before running metaphlan, I ran my samples through kneaddata.

I have tried this on two different kneaddata files, the fastq and paired fastq file.

Here is the command:
metaphlan samplename.r1_kneaddata.fastq --input_type fastq -t marker_counts -o profiled_samplename_counts.txt

This is what my file looks like:
image

When I used the paired kneaddata fastq
command: samplename.r1_kneaddata_paired_1.fastq --input_type fastq -t marker_counts -o profiled_samplename_kneaddata_paired_1_counts.txt
image

When I run the typical command with relative abundance:
image
I am getting results.

What can I do to troubleshoot this?

My last question, is that I’ve read that you cannot merge tables with counts data. Is that true? If so, is there any command that we could use to merge samples into a table?

Thank you for your help and your amazing tools!

It’s possible that the files were so big I could not see the ends and get to the counts. I will keep you posted and let you know if I’m having problems after everything finishes running!

From what I’ve found, for others wondering, the merge tables command doesn’t work unless the output is in relative abundance.