output format different

Hi Metaphlan group! I am rerunning metaphlan 3.0 on 60 marine samples and am following along in the tutorial.

When I take a look at my output table:

less -S merged_output/merged_abundance_table_con_virus.txt

the first 60 rows are the command followed by columns with ncbi taxonid and relative abundance for each sample:

Subsequently, when I run I get the

ValueError: Unsupported dtype object

I am running WSL Ubuntu 20.04.3 LTS (GNU/Linux 4.4.0-18362-Microsoft x86_64). I installed metaplan using conda install

Here are the codes I ran:

for f in `cat sample_id.txt`; do
  echo ${f}
  metaphlan ./01_Preprocessing/pp_${f}.fa --unknown_estimation --add_viruses --bowtie2out ./02_Taxonomy/metaphlan/con_virus/${f}.bowtie2.bz2 --input_type fasta --nproc 12 -o ./02_Taxonomy/metaphlan/con_virus/${f}_profile.txt
done ./02_Taxonomy/metaphlan/con_virus/*_profile.txt > ./02_Taxonomy/metaphlan/con_virus/merged_output/merged_abundance_table_con_virus.txt

Thanks for your help in getting the right format for the merged tables.