doesn't work after converting to GTDB taxonomy

The script doesnt work if when metaphlan output has been converted using the utility script. I suspect this is to do with the lower number of headers and columns.

This is what an example of my converted metaphlan output looks like:

#clade_name     relative_abundance
d__Bacteria     100.00001
d__Bacteria;p__Actinobacteriota 25.292869999999997
d__Bacteria;p__Proteobacteria   12.73789
d__Bacteria;p__Firmicutes_A     38.49073
d__Bacteria;p__Bacteroidota     18.188679999999998
d__Bacteria;p__Firmicutes       4.95885
d__Bacteria;p__Firmicutes_C     0.28645
d__Bacteria;p__Firmicutes_B     0.04454

The error code in the merged output is:
merge_metaphlan_tables: wrong header format for “13-6929606_metaphlan_gtdb.txt”, please check your profiles.

Any ideas on how to fix this?

Hi @sxh1136
Yes, currently the does not work with the profiles produced by the However, in the following days, we are going to push version 4.0.2 that will include new utilities and, between them, the merging of gtdb-transformed profiles

Thanks for the quick reply. Good to hear that a fix is coming soon. Would you recommend that I even convert SGB taxonomy to GTDB if I’m just using the metaphlan data to plot relative abundance stacked bar charts?

Hi @sxh1136
We just pushed version 4.0.2 fixing this problem (now, for GTDB profiles you will need to use the --gtdb_profiles parameter)