The bioBakery help forum

LEfSe error making plot with data containing only 2 classes

Hi all,

I’m getting an error when using the last step of the LEfSe galaxy module ( Plot LEfSe results). Error text posted below

Traceback (most recent call last):
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/./plot_res.py”, line 151, in
else: plot_histo_hor(params[‘output_file’],params,data,len(data[‘cls’]) == 2)
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/./plot_res.py”, line 54, in plot_histo_hor
if bcl: data[‘rows’].sort(key=lambda ab: fabs(float(ab[3]))*(cls.index(ab[2])2-1))
File “/shed_tools/testtoolshed.g2.bx.psu.edu/repos/george-weingart/lefse/a6284ef17bf3/lefse/./plot_res.py”, line 54, in
if bcl: data[‘rows’].sort(key=lambda ab: fabs(float(ab[3]))
(cls.index(ab[2])*2-1))
ValueError: invalid literal for float(): 3wo

I’ve encountered the same error before, but that was due to having more than 2 classes in the data. This set only has 2, and otherwise worked for a different subset that I entered just a few minutes prior.

Any help would be great, thank you so much!

Hello,

Apologies for the late reply. Would it be possible for you to provide us your input file?

Thanks,
Sagun