Issue with trimmomatic

Hello, I installed biobakery_workflows but I am running into an error with the trimmomatic tool.
biobakery_workflows wmgx --input examples/wmgx/single/ --output workflow_output

I get the following error:

Error message returned from Trimmomatic :
  Error: Invalid or corrupt jarfile /home/bench-user/.apps/conda/envs/biobakery/bin/trimmomatic

Forcing an update of trimmomatic didn´t work.

I also tried to follow both advices present in anothe thread (Kneaddata installed with conda is not available)

I edit [trimmomatic_jar=“trimmomatic*” to “trimmomatic.jar”] in python script [~/home/bench-user/.apps/conda/envs/biobakery/lib/python3.7/site-packages/kneaddata/] without success.

And finally I tried:

mkdir trim_tools
cp -r ~/miniconda3/envs/$MYENV/share/trimmomatic/adapters trim_tools/
cp ~/miniconda3/envs/$MYENV/share/trimmomatic/trimmomatic.jar trim_tools/

include the argument --trimmomatic $PWD/trim_tools
But --trimmomatic is not a valid argument in biobakery_workflows wmgx.

Does anyone have other ideas?
Thank you

This post presents a solution: Kneaddata installed with conda is not available - #5 by Ben_Siranosian

1 Like