Installing humann3

Hello, I am trying to install humann3 on the cluster. However is there a way to download the metaphlan executable.
CRITICAL ERROR: The metaphlan executable can not be found. Please check the install.

How are you installing the software (pip, conda, etc.)? Can you point me to a particular set of instructions you’re following? MetaPhlAn should be installed as part of a HUMAnN installation (since it is a dependency).

@franzosa I used a docker image since that was the only way to install it on the HPC cluster ( that’ s what I was told). Here is the slurm script.

srun --nodes=1 --ntasks-per-node=1 --mem=32G --time=60:00:00 --pty bash -i

cd /INSTALLATION_FOLDER #some folder you want to install humann
module load singularity/4.0.3
singularity pull docker://biobakery/humann
./humann
humann_databases #list of databases
humann_databases --download chocophlan full ./
humann_databases --download uniref uniref90_diamond ./
humann_databases --download utility_mapping full ./
exit

Hi,
I think you should be able to use conda on an HPC, which would be a bit easier.
However, for some tasks container images could be a good idea in terms of reproducibility. I see you’re pulling the image but you seem not to run it in the code you provided. But I don’t see how you would then get the metaphlan error without actually running the image. Which line throws the error, and is your exec command missing from these lines?
Best,
Barbara

Hi, the post was a response to the question how I was installing.I ran humann_test, I get two errors (screenshot). I ignored it but when I ran the demo run using the example datasets, I get the error that I first posted.