HUMAnN3 v3.7 database error "Please install the latest version of the database: 201901b"

Edit: I figured out what was wrong. I managed to get it running in a clean conda environment. I was initially trying using a new singularity image I had built, but singularity used an old cached copy of an older version of the container based on the same singularity deffile. Problem solved!

Leaving the rest of the post here in case it helps someone else in the future. I still find the naming conventions of the HUMAnN databases confusing, but it appears it was not the databases that were the issue this time.

I’m having trouble running HUMAnN3 v3.7 with the latest database versions available.

Hoping someone can help me figure what I’m doing wrong. I have read all the other threads I have found about HUMAnN3 and database issues, but nothing seems directly similar to my problem.

When I run HUMAnN3 v3.7 using what I think are the latest databases:

  • chocophlan_v201901_v31
  • uniref90_201901b_full

I get the following error message:

CRITICAL ERROR: The directory provided for ChocoPhlAn contains files (g__candidate_division_Zixibacteria_unclassified.s__candidate_division_Zixibacteria_bacterium_HGW_Zixibacteria_1.centroids.v201901_v31.ffn.gz) that are not of the expected version. Please install the latest version of the database: 201901b

I thought chocophlan v201901_v31 was the latest?

The official database download tool humann_databases lists the following:

$ humann_databases
HUMAnN Databases ( database : build = location ) chocophlan : full = chocophlan : DEMO = uniref : uniref50_diamond = uniref : uniref90_diamond = uniref : uniref50_ec_filtered_diamond = uniref : uniref90_ec_filtered_diamond = uniref : DEMO_diamond = utility_mapping : full =

Based on what I can see at the URL where the tool downloads its databases from, Index of /humann_data/chocophlan/, the version with the most recent date is actually full_chocophlan.v201901_v31.tar.gz and not full_chocophlan.v296_201901b.tar.gz (which is what I think the error message wants me to use?).What have I done wrong? Did I run with the wrong combination of databases?

Is v296_201901b actually the latest version, despite having a date listed at the download URL that is one year older than the v201901_v31 database?

I see now in the release announcement for HUMAnN 3.6, it says::

You DO NOT need to re-download the latest (v3.1) pangenome database

I’m interpreting this to mean that is actually the latest ChocoPhlAn database to use, and not the 201901b variant the error message hinted at. Maybe updating that error message was overlooked in a recent release?

I am not sure how to proceed from here. I find version numbering of the HUMAnN database very confusing. Am I really supposed to be combining chocophlan database v201901_v31 with uniref 201901b?

I am currently trying to redownload the latest databases (full_chocophlan.v201901_v31.tar.gz and uniref90_annotated_v201901b_full.tar.gz) from the URLs listed above to see if there is something wrong with my local copies.

Glad you managed to solve the problem! (See OP’s bolded comment at the top of the initial post for a solution.)