Humann v3.9 sam file input error

I have the output files of metaphlan version 4.0.6 (1 march 2023) in .sam.bz2 format. I unzipped the bz2 files by command bzip2 -d and got .Sam files. I used these .Sam files for humann v3.9 and humann v3.8. I downloaded the databases from biobakery3 uniref90_annotated_v201901b_full.tar.gz
and full_mapping_v201901b.tar.gz.
After that I run the simple command
humann --input ./SRR18844950.sam --output ./Human
It creates three output files sample_genefamiles.tsv etc and all the files were empty just having the information like # Gene Family SRR18844948_Abundance-RPKs
UNMAPPED 6049261.0000000000.
I tried to unzip the databases. Is there any compatibility reason with metaphlan version 4.0.6 output or any other issue? I wanna resolve this issue and want to run humann v3.9 at my .Sam files of metaphlan version 4.0.6

Hi, Sorry for any confusion! HUMAnN will take sam files as input but it does not expect the sam files output from MetaPhlAn. You can provide the same fastq file you provided to MetaPhlAn as input to HUMAnN and by default it will run MetaPhlAn as part of its process. Please post if you have any additional questions or issues!