The bioBakery help forum

How to set min_alignment_len

Hello everyone!

I am trying to have taxonomical data from SRR1778456, and I got some questions. First sorry if it is very obvious question, and thank you for your kindness. The SRR1778456 has read length of 90. so if I use --bt-ps -very-sensitive-local option and min_alignment_len 100 as default, it gets nothing as result. So I’ve been trying to set min_alignment_len under 90 and tried 70, 60, 50 and got all different results. Is there any guidelines to set min_alignment_len ? or do you have any suggestions?

Thanks again!

SRR1778456 is a short-read metagenome, I’d advise you to run MetaPhlAn using the default end-to-end preset. The local alignment option is advisable to use when you have reads longer than 150 bp.