How can I expand the max amount of memory at running trimmomatic?


I’m running kneaddata on my metagenomic samples and everything works perfectly.

but I have a trivial issue.

I used an option --max-memory 10000m in trimmomatic arguments,
but when check the log file, the max-memory is still fixed at 500m.
My working environment has enough RAM available.

How can I expand maximum memory for trimmomatic?

Maybe I’m misunderstood?
I thought --max-memory 500m means “Setting the maximum memory available during trimmomatic to 500MB”.

Please advise me.

Thank you.

Sorry for the poor question.
This issue was about the permissions of my linux account, and I bypassed it by editing the script in