The bioBakery help forum

Adapter file isn't passed to trimmomatic when some trimmomatic options are specified

Hello,
recently I noticed trimmomatic wasn’t trimming the adapters. In this case are Nextera, so I specified “NexteraPE”. I know this is the default, but I tend to specify most of the options for clarity. The result was a successful run of kneaddata, but the reads still had all the adapters.
I noticed that if some trimmomatic options are specified , the command generated by kneaddata doesn’t contain the adaptors file, so as a consequence, there is no adapters’ trimming. The options I’m referring to are --sequencer-source and --trimmomatic-options, one or both, when specified, generate a command that doesn’t contain the adapter file. Options --max-memory and trimmomatic don’t seem to have this problem.

$ kneaddata --version
kneaddata v0.10.0

Hi @matrs ,

How is Kneaddata being installed in your system at the moment? Is it through pypi? Below I have listed adapters that are supposed to be installed in the /kneaddata/adapters directory through the setup script.

My guess is that the following files are missing which is why the adapters are not being trimmed. Please feel free to add the following files manually in the adapters directory.

"https://raw.githubusercontent.com/timflutre/trimmomatic/master/adapters/TruSeq2-PE.fa"
"https://raw.githubusercontent.com/timflutre/trimmomatic/master/adapters/TruSeq2-SE.fa"
"https://raw.githubusercontent.com/timflutre/trimmomatic/master/adapters/TruSeq3-PE.fa"
"https://raw.githubusercontent.com/timflutre/trimmomatic/master/adapters/TruSeq3-SE.fa"
"https://raw.githubusercontent.com/timflutre/trimmomatic/master/adapters/NexteraPE-PE.fa"

Regards,
Sagun