The bioBakery help forum

Graphlan metadata name manipulation

So I have a tree generated for strainphlain with metadata added, but the png I generate with graphlan cuts off the value of the SubjectID I want.
For example:
My subject ID would be Rhyticeros_undulatus in my tre.metadata, but the resulting image would show my subjectID as Rhyticeros.

Is there a way for graphlan to ignore “_” when parsing the tre.metadata file? If not, if there a clever way to have metadata values as two terms without directly joining them like “RhyticerosUndulatus”?

input of tre.metadata file

output legend from graphlan
image

Command I use to run graphlan:
plot_tree_graphlan.py -t RAxML_bestTree.s__Escherichia_coli.StrainPhlAn3.tre.metadata -m SubjectID

Hi Jeffrey -

I am not sure why this is happening. It could be for several reasons. There are a couple of things we could try to debug-

  1. Have you tried a different character for the _ : perhaps a “.” or a space?
  2. Use the regular GraPhlAn utility instead of this script: see here
  3. Use the R-scripts (below this example on the tutorial) instead of the GraPhlAn version for tree construction. ggtree has some great tree visualizing abilities. The scripts themselves should be stored in the breadcrumbs github

If none of those options work for you - can you send us a minimally reproducible example of this issue?

Best,
Kelsey