The bioBakery help forum

Format_input.py error in docker

Hi all!

I tried to reproduce example file “hmp_small_aerobiosis.txt” with my own NGS data but got an error:
nirS_lefse_data.txt (5.6 KB)

linuxbrew@3ec4cabc7a4f:~$ format_input.py lefse_data_nirs.txt lefse_data_nirs.in -c 1 -s 2 -u 3
Traceback (most recent call last):
File “/home/linuxbrew/.linuxbrew/Cellar/lefse/1.0.0-dev-e3cabe9/libexec/bin/format_input.py”, line 408, in
first_line = modify_feature_names(list(first_line))
File “/home/linuxbrew/.linuxbrew/Cellar/lefse/1.0.0-dev-e3cabe9/libexec/bin/format_input.py”, line 260, in modify_feature_names
if r[0] in [‘0’,‘1’,‘2’,‘3’,‘4’,‘5’,‘6’,‘7’,‘8’,‘9’]:
IndexError: string index out of range

Also, I tried to upload the same file to the Galaxy but at “Format Data …” step I can’t set variables for Class, Subclass etc. because they are not switchable.

Tell me please what I’m doing wrong?

Thanks a lot!

Hi @andrewK,

Thank you for supplying your table! I am not 100% sure what is going on here. When I downloaded the table as is and tried to upload it I was seeing the same issue you are on galaxy. I opened the file in excel to see if I saw anything wrong - I didn’t. So I re-saved it as a tab-deliminated file (.txt - which it already appears to be) and re-uploaded and this time it worked. Can you try that? Just open in excel and save as .txt?

If that doesn’t work let me know!
Best,
Kelsey