Error with bowtie2-build when running humann3

Hi community,

I recently get the error with the following error when running Humann3:

Total species selected from prescreen: 674

Selected species explain 99.66% of predicted community composition

Creating custom ChocoPhlAn database …

Running bowtie2-build …

CRITICAL ERROR: Error executing: …

I try many times but still not solve this problem.
The last try was, I installed metaphlan4 first, and installed humann3, and run metaphlan4, there is no error.
But this error was obtained when I run humann3.

humann v3.8
MetaPhlAn version 4.0.6 (1 Mar 2023)
bowtie2 version:
miniconda3/envs/humann3/bin/bowtie2-align-s version 2.5.1
Built on fv-az456-736
Tue Jan 31 03:03:11 UTC 2023
Compiler: gcc version 10.4.0 (conda-forge gcc 10.4.0-19)
Options: -O3 -msse2 -funroll-loops -g3 -fvisibility-inlines-hidden -std=c++17 -fmessage-length=0 -march=nocona -mtune=haswell -ftree-vectorize -fPIC -fstack-protector-strong -fno-plt -O2 -ffunction-sections -pipe -isystem /home/qli/miniconda3/envs/humann3/include -fdebug-prefix-map=/opt/conda/conda-bld/bowtie2_1675132819676/work=/usr/local/src/conda/bowtie2-2.5.1 -fdebug-prefix-map=/home/qli/miniconda3/envs/humann3=/usr/local/src/conda-prefix -std=c++11 -DPOPCNT_CAPABILITY -DNO_SPINLOCK -DWITH_QUEUELOCK=1 -DWITH_ZSTD
Sizeof {int, long, long long, void*, size_t, off_t}: {4, 8, 8, 8, 8, 8}

The command for humann3 is:
humann --metaphlan-options “–index mpa_vOct22_CHOCOPhlAnSGB_202212 --bowtie2db #the folder” --input-format fastq --input sample.fastq --output humann3_out --memory-use maximum

Does anyone have ideas? Thanks for your time in advance.

Full error is:

CRITICAL ERROR: Error executing: /home/qli/miniconda3/envs/humann3/bin/bowtie2-build -f /run/user/1001/gvfs/smb-share:server=lab-dna.local,share=%20lab/humann3_out/1008C1_humann_temp/1008C1_custom_chocophlan_database.ffn /run/user/1001/gvfs/smb-share:server=lab-dna.local,share=%20lab/humann3_out/1008C1_humann_temp/1008C1_bowtie2_index

OK, I think the problem is metaphlan cannot call the files from the share folder. The input files for the bowtie2-build is generated in the same share folder (because I set the --output to the share folder), even if I can access from my own computer. I run in my local computer, and it seems worked : )

Glad you were able to figure it out!

1 Like