Error in kneaddata

Hi all
I am new to kneaddata
I installed kneaddata using the
but when I ran the first code, i got an error
kneaddata --input1 /media/sf_Shared_folder/ovas/Final/81_R1.fastq --input2 /media/sf_Shared_folder/ovas/Final/81_R2.fastq --reference-db /media/sf_Shared_folder/Homo_sapiens/Homo_sapiens/UCSC/hg19/Sequence/BowtieIndex/ --output /home/qiime2/Desktop/ovas/
ERROR: Unable to find trimmomatic. Please provide the full path to trimmomatic with --trimmomatic.
then i checked with kneaddata, I have trimmomatic installed
kindly guide
thanks in advance

Hi again
While going through previous posts I got that the issue is mainly because I don’t have the jRE installed on my environment.
Although I downloaded it, but I don’t know how to install it.
I have copied the tar. gz on destktop of my linux system.
Kindly guide how and where to install
Thanks and regards

Hi again
any guide in the above error is highly appreciated

I tried to reinstall kneaddata and run again now it gave this error

kneaddata: error: ambiguous option: --input could match --input1, --input2

Hi @ Franzosa
I am getting this error

Hi Muneer,

This is what I did.

Create kneaddata (version 0.7.4) environment via conda

$ conda create --name kneaddata
$ source activate kneaddata
$ conda install -c cyclus java-jre
$ conda install -c bioconda fastqc
$ conda install -c bioconda trf
$ conda install -c bioconda kneaddata
$ conda install pip
$ pip install kneaddata

Install Trimmomatic version 0.33. Not via conda

$ curl -o
$ unzip

#keep note of the install location. Will need to provide its path to keanddata

Install kneaddata human contamination databases.
Everything within and including the greater/less than symsbols “< >” should be replaced.

$ kneaddata_database --download human_genome bowtie2 <path/to/install/kneaddata_database>

Hi @ aimirza
thank you for your help
I successfully installed kneaddata
but while running the command got this error
kneaddata –input1 /media/sf_Shared_folder/ovas/Final/81_R1.fastq --input2 /media/sf_Shared_folder/ovas/Final/81_R2.fastq --reference-db /home/qiime2/ref_dtabase/ --output kneaddata_81 --trimmomatic /home/qiime2/Trimmomatic-0.33
Reformatting file sequence identifiers …

Reformatting file sequence identifiers …

Reordering read identifiers …

Initial number of reads ( /home/qiime2/kneaddata_81/reordered_qhik9bbx_reformatted_identifierse3uxy95f_81_R1 ): 22625162.0
Initial number of reads ( /home/qiime2/kneaddata_81/reordered_enctz3x3_reformatted_identifiersd8ic66o3_81_R2 ): 22625162.0
Running Trimmomatic …
CRITICAL ERROR: Error executing: java -Xmx500m -jar /home/qiime2/Trimmomatic-0.33/trimmomatic-0.33.jar PE -threads 1 -phred33 /home/qiime2/kneaddata_81/reordered_qhik9bbx_reformatted_identifierse3uxy95f_81_R1 /home/qiime2/kneaddata_81/reordered_enctz3x3_reformatted_identifiersd8ic66o3_81_R2 /home/qiime2/kneaddata_81/81_R1_kneaddata.trimmed.1.fastq /home/qiime2/kneaddata_81/81_R1_kneaddata.trimmed.single.1.fastq /home/qiime2/kneaddata_81/81_R1_kneaddata.trimmed.2.fastq /home/qiime2/kneaddata_81/81_R1_kneaddata.trimmed.single.2.fastq MINLEN:60 ILLUMINACLIP:/home/qiime2/miniconda/envs/kneaddata/lib/python3.8/site-packages/kneaddata/adapters/NexteraPE-PE.fa:2:30:10:8:TRUE SLIDINGWINDOW:4:20 MINLEN:75

Error message returned from Trimmomatic :
<JAVA_HOME>/lib/ext exists, extensions mechanism no longer supported; Use -classpath instead.
.Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
kindly suggest further