Broken Pipe Error in MetaPhlAn 4

I have tried running the tutorial file Supragingival plaque in my conda-installed MetaPhlAn 4. However, I keep encountering the same error

(metaphlan) sasaki@LAPTOP-9RD:~$ metaphlan SRS014476-Supragingival_plaque.fasta.gz  --input_type fasta > SRS
(ERR): bowtie2-align exited with value 137
Traceback (most recent call last):
  File "/home/user/anaconda3/envs/metaphlan/bin/", line 10, in <module>
  File "/home/user/anaconda3/envs/metaphlan/lib/python3.7/site-packages/metaphlan/utils/", line 168, in main
    f_nreads, f_avg_read_length = read_and_write_raw(f, opened=False, min_len=min_len, prefix_id=prefix_id)
  File "/home/user/anaconda3/envs/metaphlan/lib/python3.7/site-packages/metaphlan/utils/", line 130, in read_and_write_raw
    nreads, avg_read_length = read_and_write_raw_int(inf, min_len=min_len, prefix_id=prefix_id)
  File "/home/user/anaconda3/envs/metaphlan/lib/python3.7/site-packages/metaphlan/utils/", line 109, in read_and_write_raw_int
    print_record(description + "__{}{}{}".format(prefix_id, '.' if prefix_id else '', idx), sequence, qual, fmt))
BrokenPipeError: [Errno 32] Broken pipe```

Hi @sasakitomiyano
It seems bowtie2 crashed due to lack of memory. For the metaphlan 4 execution, a machine with at least 15GB of RAM free is needed