The bioBakery help forum

Biobakery_workflows wmgx_vis: Package inputenc Error, running pandoc fails

So I have been trying to run the visualization workflow wmgx_vis. However, I keep getting an error that the workflow cannot produce a pdf with the character beta.

anadama2.util.ShellException: [Errno 43] Command `pandoc $PATH_INPUT/ -o $PATH_OUTPUT/wmgx_report..pdf --variable=linkcolor:Blue --variable=toccolor:Blue --pdf-engine=pdflatex --standalone --toc' failed. 
  Out: b''
  Err: b'Error producing PDF.\n
! Package inputenc Error: Unicode character \xce\xb2 (U+03B2)\n
(inputenc)                not set up for use with LaTeX.\n\n
See the inputenc package documentation for explanation.\n
Type  H <return>  for immediate help.\n ... \n\n
l.360 dTDP-\xce\xb2-L-rhamnose biosynthesis}\n\n
Try running pandoc with --pdf-engine=xelatex.\n'

Basically, wmgx_vis calls pandoc in order to create a pdf. However, the character \xce\xb2, which is beta, is not recognized. I looked up where the call for pandoc is defined, and it is defined in anadama2/

# set the pandoc command based on if a table of contents will be included
pandoc_command="pandoc {0} -o {1} --variable=linkcolor:Blue "+\
"--variable=toccolor:Blue --pdf-engine=pdflatex --standalone" 

I tried to call pandoc with --pdf-engine=xelatex instead of pdflatex. However, this solution didn’t work.
Any other solutions?

Hello, Thank you for the detailed post. We have tested the workflows with the pdflatex engine but not the xelatex engine so I am not sure if it is able to compile the document.

Have you tried updating your workflows to the latest version? You also might try re-installing latex to see if this resolves the issue.

Thank you,

Sorry for the late reply.
I did update the workflow to the latest version + re-installed latex several times to no avail.
That said, I had to run the workflow in a conda environment with python version 3.6 and not 3.7.
The reason for that is elaborated in the following post:
(I should have most probably looked at pweave version 0.25, but didn’t for some reason -…v0.30.1 )