R session aborted when running random_effect

Hi everyone,

I have a problem with paired sample when running Maasslin2.

I am a newbie and I have a count dataset with paired sample (tumor and non-tumor) for each subject. I run Maaslin2 with Subject as a random effect and Group (tumor and non-tumor) as fixed effects, but R session aborted (R encountered a fatal error). But when I run with just fixed effect, Maaslin2 run completely.

This is Maaslin2 code:
input_data, input_metadata, output,
min_prevalence = 0.1,
normalization = “TMM”,
transform = “NONE”,
analysis_method = “NEGBIN”,
fixed_effects = c(“Group”),
random_effects = c(“Subject”),

Is something wrong?

Hope to receive help from everyone!


Hi there @tanhoadn,

Unfortunately I cannot really work out why this is occurring without a reproducible example would you be able to share some data that causes this? One thing to check would be if there are any odd characters in the sample name or metadata.

Jacob Nearing

Hi @nearinj

Thank you for your reply!

I send you a part of my data. Hope you can check and help me to see where the problem is.

df.20.csv (502 Bytes)
otu.20.csv (15.6 KB)

Many thanks,

I ran into the same issue where the model without random_effect (batch variable in my case) works fine, but when I ran the model including random_effect option, my R session aborted. We may have different causes for the problems, but I’m curious if you have solved the issue. If so, how?

Thank you!

Hi @vicky291

I have not known where the problem is. But when I exported input.csv and metadata.csv, then I ran it in a new R session (just run for Maaslin package), it worked. Hope this helps!


1 Like