The bioBakery help forum

Kneaddata:Bowtie2 error: skipping reads

Hi all, I am using kneaddata with bowtie2. Using the default parameters with trimmomatic options (trimmomatic_options = MINLEN:12 SLIDINGWINDOW:4:15) my log file showed warnings of the following type repeating several times:

Warning: skipping read ‘####’ because length (1) <= # seed mismatches (0) Warning: skipping read ‘####’ because it was < 2 characters long

But when I use kneaddata with default parameters I do not get this warning, however, end up getting fewer reads as compared to using the modified parameters.

I have the following questions:

Does this mean there is a problem with my reads? If so how to find that out? Should I avoid changing the trimmomatic parameters? Do you think that can cause the reads to be filtered out here? Will I lose these reads in the next steps to come if I use default parameters?

Any help would be appreciated

Thank you

Hi @Dhrati_Patangia,

Thank you for reaching out to the biobakery lab. I think setting the trimmomatic_options = MINLEN:12 SLIDINGWINDOW:4:15 is causing the problem as the value of MINLEN is very low i.e 12.

[ DEFAULT : SLIDINGWINDOW:4:20 MINLEN:50 ]
MINLEN is set to 50 percent of total input read length. 
The user can alternatively specify a length (in bases) for MINLEN.

Based on your input bp, you should be setting your trimmomatic options. We use the above value as default for Kneaddata.

Regards,
Sagun