Invalid p-value correction options

I’m having trouble running MaAsLin2 with my desired p-value correction method (bonferroni) on CLR-transformed microbiome data. I have already set up the analysis as follows, with my behavioural covariates of interest set up as fixed effects:

fit_data_TCR = Maaslin2(
    input_data = clr_otu_TCR, 
    input_metadata = meta_behav, 
    max_significance = 0.1,
    min_prevalence = 0,
    standardize = TRUE,
    output = "output_TCR", 
    analysis_method = "LM",
    normalization = "NONE",
    transform = "NONE",
    correction = 'bonferroni', 
    fixed_effects = c("SEX", "DoubleHit","OF_Rearing","OF_Tot_distancecm","SOC_HAB_DIST",
                      "SOC_DIST" ,"SOC_CENT_CHAMBs"  , "GROOM_FREQ",
                      "GROOM_DUR" , "GROOM_LAT","SOC_SCORE" ),
    reference = 'DoubleHit,NS')

However, when running the code I receive this error:

"ERROR::Please select a correction method from the list of available options : BH, holm, hochberg, hommel, bonferroni, BY"

No matter what I do, even typing it out by hand, it seems that MaAsLin2 won’t accept any arguments from this list other than “BY” and “BH”. everything else throws the same error. When I run the same code above with correction = "BH" it works just fine, but I want the bonferroni correction for consistency with my other analyses.

Any advice would be appreciated!

Hi @mirpie,

Apologies for my delayed response! We noticed this error about a month ago and have applied a fix to the current developmental version of MaAsLin in github. If you install MaAsLin from source, the code should work as you have it there. It will also be pushed to Bioconductor soon - if you don’t want to install it from source. Thanks for this bug report!