Error,Dependencies

Hello,
When I try to install MelonnPan on R version 3.5 I got a problem which about
" ERROR: dependencies ‘glmnet’, ‘GenABEL’, ‘GenABEL.data’ are not available for package ‘melonnpan’

  • removing ‘/Users/chalaemkwan/Library/R/3.5/library/melonnpan’
    Error in i.p(…) : "
    Can anyone fix this problem for me, please?

The latest version of glmnet requires R version >=3.6.0—it is not available for R version 3.5. The bioBakery Vagrant image uses glmnet version 2.0-18, which can be installed with this command.

R -q -e "devtools::install_version('glmnet', version = '2.0-18', repos = 'http://cran.us.r-project.org')"

For GenABEL you should also be using the devtools:install_version command as mentioned here:

https://bitbucket.org/biobakery/biobakery/wiki/melonnpan#rst-header-installation

I’m using R 3.6.
I was able to install GenABEL (and GenABEL.data), but the installation of melonnpan is failing due to:

Error: (converted from warning) package 'glmnet' was built under R version 3.6.2
Execution halted

Any ideas how to fix this?

Many many thanks