Wrong result in output data metawibele preprocess

Dear Yancong Zhang,
I tried to install MetaWIBELE and requirements using conda. I almost managed to install all except Interproscan. I couldn’t add it into PATH. I always need to go the folder to run it.

However, when I run metawibele preprocess --input raw_reads/ --output demo_metawibele/ --output-basename demo --extension-paired "_R1.fastq.gz,_R2.fastq.gz" --extension ".fastq.gz" --local-jobs 4 using the data provided in the tutorials for 2 samples, it runs without error but when I look at demo_genecatalogs_counts.all.tsv file I have this results:

ID sample1 sample2
sample1_2-1 67 5

I don’t think this is right but I don’t know where the issue is. Could you please help me with this and how can I also run Interproscan in any directory.

Thank you so much for your help.

All the best,

Hi Bahti,

Re1: The resulting demo_genecatalogs_counts.all.tsv file looked fine. Since the gene caller in the preprocess module assigned gene IDs in a slightly random way, you might get different IDs for different run, but the resulting reads counts and sequences should be consistent. That’s why you saw your gene ID differed from that on the tutorial page.

Re2: To run Interproscan in any location, you may want to add the Interproscan’s executive command interproscan.sh into your $PATH, and customize the path of Interproscan in metawibele.cfg (i.e. interproscan_cmmd = interproscan.sh).


Thank you so much. I’ll do your suggestion and let’s see if I am able to run it.
All the best,