Weird error in Maaslin2

Dear all,
I have tried to command line that was working before and txt file that I have used to analyze before but now it is not working at all. Then I tried with the example provided with Maaslin2 and I have run this command line:

fit_data <- Maaslin2("~/Desktop/HMP2_metadata.tsv", "~/Desktop/HMP2_taxonomy.tsv", "~/Desktop/Overall/", min_abundance=0.000000001, min_prevalence=0.3, max_significance=0.2)

It gives me this error:

2020-01-31 13:24:40 INFO::Running selected normalization method: TSS
Error in FUN(newX[, i], …) : invalid ‘type’ (character) of argument
In addition: Warning message:
In vegan::decostand(features_norm, method = “total”, MARGIN = 1, :
input data contains negative entries: result may be non-sense

I have tried to re-install it and still it is not working. I have updated the several R packages a couple of weeks ago I am not sure if that caused a problem. Here is further information and by the way I am using MAC OS X 10.14.6

sessionInfo(package = NULL)
R version 3.6.2 (2019-12-12)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS Mojave 10.14.6

Matrix products: default
BLAS: /System/Library/Frameworks/Accelerate.framework/Versions/A/Frameworks/vecLib.framework/Versions/A/libBLAS.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods base

other attached packages:
[1] Maaslin2_0.99.12

loaded via a namespace (and not attached):
[1] hash_2.2.6.1 Rcpp_1.0.3 rstudioapi_0.10 cluster_2.1.0 magrittr_1.5 splines_3.6.2 MASS_7.3-51.5 tidyselect_0.2.5
[9] getopt_1.20.3 lattice_0.20-38 R6_2.4.1 rlang_0.4.3 dplyr_0.8.3 tools_3.6.2 parallel_3.6.2 grid_3.6.2
[17] nlme_3.1-143 data.table_1.12.8 mgcv_1.8-31 vegan_2.5-6 logging_0.10-108 assertthat_0.2.1 tibble_2.1.3 optparse_1.6.4
[25] permute_0.9-5 crayon_1.3.4 Matrix_1.2-18 lpsymphony_1.14.0 purrr_0.3.3 glue_1.3.1 compiler_3.6.2 pillar_1.4.3
[33] pkgconfig_2.0.3

Thank you so much in advance. Looking forward to hear your suggestions.

Best wishes,

Today, even I have tested using our university cluster and I got the same error in Linux too. Therefore this doesn’t seem as MacOS issue. Probably global with updated dependency.

Any suggestions?

Best wishes,

Hi Bahti,

Sorry that you are having issues with MaAsLin2! These are harder questions for me to answer without being able to replicate the issues on our side. Have you tried to run the model on data tables in R instead of text files? The error itself while vague appears to be an issue with the presence of some sort of character in the metadata that cannot be run through vegan.

I would examine the feature table and the metadata as data tables, then try MaAsLin2. If that does not work can you send a minimum reproducible example with the error so we can try to replicate? You can scrub the metadata or send a dummy set that still causes the issues on your interface. Hopefully, that helps! Please let us know if it doesn’t.

You can also try to install the latest version of MaAsLin2 through Bioconductor (, a side note on that is that you will need BioC of 3.10 to install MaAsLin2 correctly.


Dear Kelsey,

Thank you so much for your reply. I tried to install MaAsLin2 through Bioconcuctor too but it didn’t work. Example that I used to run is the one that you provided in Maaslin folder. But anyway I uploaded themn here again:

I run:
fit_data <- Maaslin2("~/Desktop/HMP2_metadata.tsv", “~/Desktop/HMP2_taxonomy.tsv”, “~/Desktop/Overall/”, min_abundance=0.000000001, min_prevalence=0.3, max_significance=0.2)

I have now tried also using datatables after replacing the space with “_” and I just got an error:

Error in FUN(newX[, i], …) : invalid ‘type’ (character) of argument.

I am not sure but I feel like this all related with one of the packages that I updated recently. Because I have used this pipeline until 10 days ago. Out of nowehere it started to give this error.

Thank you so much for your help.

Kind regards,

Hey Kelsey,
I think there is something wrong with HMP2_metadata and taxonomy file because now I changed it to my own files back and if I run the model on data table it works but now as text file. That’s weird but anyway it works.
Thank you so much for your help and time.
All the best,

Hi Bahti,

That’s great to hear, I’ll look into the files so that we don’t run into the issue again!